- In a first step, I have configured my network without summarization:
interface Loopback10
ip address 10.1.0.1 255.255.255.0
!
interface Loopback20
ip address 10.1.1.1 255.255.255.0
!
interface Loopback30
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
R2:
interface Loopback10
ip address 192.168.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.1.2 255.255.255.0
!
router eigrp 1
network 192.168.0.0 0.0.255.255
Results (on R2):
R2# show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 3 subnets
D 10.1.0.0 [90/409600] via 192.168.1.1, 00:01:11, FastEthernet0/1
D 10.1.1.0 [90/409600] via 192.168.1.1, 00:01:11, FastEthernet0/1
D 10.1.2.0 [90/409600] via 192.168.1.1, 00:01:11, FastEthernet0/1
As you can see, 3 subnets are seen in the routing table of R2.
- Now, I have configured summary network on R1:
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip summary-address eigrp 1 10.1.0.0 255.255.252.0
Results (on R2):
R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/22 is subnetted, 1 subnets
D 10.1.0.0 [90/409600] via 192.168.1.1, 00:00:39, FastEthernet0/1
Only one summarized subnet is seen on R2.
- The final step is to configure the route leaking on R1:
ip access-list standard LEAK-MAP
permit 10.1.1.0 0.0.0.255
!
route-map LEAK-MAP permit 10
match ip address LEAK-MAP
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip summary-address eigrp 1 10.1.0.0 255.255.252.0 100 leak-map LEAK-MAP
Results (on R2):
R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.1.0.0/22 [90/409600] via 192.168.1.1, 00:06:10, FastEthernet0/1
D 10.1.1.0/24 [90/409600] via 192.168.1.1, 00:00:34, FastEthernet0/1
Both subnet are seen on R2:
- Summarized (10.1.0.0/22)
- Specific (10.1.1.0/24)
For me, it's impossible to realize an equivalent configuration with OSPF.
Don't hesitate to leave a comment if you have already seen this configuration for OSPF.
In fact, with OSPF the following configuration can be used:
ReplyDeleteR1:
==
router ospf 1
router-id 1.1.1.1
summary-address 10.1.0.0 255.255.252.0
summary-address 10.1.1.0 255.255.255.0
redistribute connected subnets
network 192.168.1.0 0.0.0.255 area 0
On R2, we can see:
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O E2 10.1.0.0/22 [110/20] via 192.168.1.1, 00:05:48, FastEthernet0/1
O E2 10.1.1.0/24 [110/20] via 192.168.1.1, 00:00:07, FastEthernet0/1
This configuration is only on ASBR when you are summarizing externet routes. What about summarizing OSPF intra-area routes on ABR?
DeleteHello,
DeleteI have just tested it with the following configuration:
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
area 1 range 10.1.1.0 255.255.255.0
area 1 range 10.1.0.0 255.255.252.0
network 10.1.0.0 0.0.255.255 area 1
network 192.168.1.0 0.0.0.255 area 0
As you can see, we have the same behavior with an ABR on R2:
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O IA 10.1.0.0/22 [110/11] via 192.168.1.1, 00:00:28, FastEthernet0/1
O IA 10.1.1.0/24 [110/11] via 192.168.1.1, 00:00:05, FastEthernet0/1