Showing posts with label vrf. Show all posts
Showing posts with label vrf. Show all posts

Tuesday, April 19, 2011

Communication entre VRF (Astuce)

Le but des VRFs est de cloisonner plusieurs instances de routage sur les mêmes équipements.
Cependant, à des fins de tests ou pour une config un peu particulière il peut être souhaité de faire communiquer 2 VRFs entre elles. Pour se faire, il existe une petite astuce qui consiste à tirer un câble entre 2 ports du switch et de les configurer en tant qu'interface de niveau 3. Le schéma ci-dessous est un exemple de cette configuration:


La configuration à appliquer:


ip vrf VRF_A
rd 2:2
!
ip vrf VRF_B
rd 3:3
!

ip vrf VRF_B

rd 4:4

!

vlan 200

name in_VRF_A

!

vlan 100

name in_VRF_B

!

vlan 150

name in_VRF_C

!

interface GigabitEthernet10

no switchport

ip vrf forwarding VRF_A

ip address 10.10.10.10 255.255.255.0

!

interface GigabitEthernet11

no switchport

ip vrf forwarding VRF_B

ip address 10.10.10.20 255.255.255.0

!

interface GigabitEthernet12

no switchport

ip vrf forwarding VRF_A

ip address 10.10.11.10 255.255.255.0

!

interface GigabitEthernet11

no switchport

ip vrf forwarding VRF_C

ip address 10.10.11.20 255.255.255.0

!

interface Vlan100

ip vrf forwarding in_VRF_A

ip address 100.100.100.100 255.255.255.0

!

interface Vlan150

ip vrf forwarding in_VRF_C

ip address 150.150.150.150 255.255.255.0

!

interface Vlan200

ip vrf forwarding VRF_B

ip address 200.200.200.200 255.255.255.0

!
ip route vrf VRF_A 100.100.100.0 255.255.255.0 10.10.10.20
ip route vrf VRF_A 150.150.150.0 255.255.255.0 10.10.11.20

!

ip route vrf VRF_C 100.100.100.0 255.255.255.0 10.10.11.10

ip route vrf VRF_C 200.200.200.0 255.255.255.0 10.10.11.10

!

ip route vrf VRF_B 150.150.150.0 255.255.255.0 10.10.10.10

ip route vrf VRF_B 200.200.200.0 255.255.255.0 10.10.10.10