Showing posts with label spanning-tree. Show all posts
Showing posts with label spanning-tree. Show all posts

Monday, March 9, 2015

Migrate from spanning-tree redundancy to LACP

Just a small memo of how migrate from spanning-tree redundancy to LACP with the minimum of outage.
If you follow these steps, you will normally not loose the control to your remote switch (or just during the spanning-tree convergence time).

Before the beginning of the migration, we have the following topology:

Start of the migration:

Access switch:
interface Gig 0/2
shut

Core switch:
int port-channel 10
shut
!
default interface Gi0/2
!
interface Gi0/2
channel-group 10 mode active
!
int po 10
switchport mode trunk
switchport trunk allowed vlan all



Core switch:
interface Gi0/2
shut

Access switch:
interface port-channel 1
!
default interface Gig 0/2
!
int Gig 0/2
channel-group 1 mode active
!
int po1
switchport mode trunk
switchport trunk allowed vlan all
no shut


Core switch:
interface port-channel 10
no shut




Access switch:
int Gig 0/1
shut

Core switch:
default int Gi0/1
!
int Gi0/1
switchport mode trunk
switchport trunk allowed vlan all
channel-group 10 mode active


Core switch:
int Gi0/1
shut

Access switch:
default int Gig 0/1
!
int Gig 0/1
switchport mode trunk
switchport trunk allowed vlan all
channel-group 1 mode active

Core switch:
int Gi0/1
no shut

Monday, July 21, 2014

TCN received from stackport1 on 3750

I was troubleshooting a network issue and during this time, I have done the following command on a 3750 stack:

show spanning-tree vlan 200 detail
Bridge Identifier has priority 20480, sysid 200, address a8b1.d36f.c670
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 8392, address 0021.e809.0670
  Root port is 568 (Port-channel11), cost of root path is 3
  Topology change flag not set, detected flag not set
  Number of topology changes 27 last change occurred 1w2d ago
          from StackPort1


As you can see, the source of the TCN is the StackPort1 on the switch!!!
But what is the meaning of this StackPort1 and how to determinate the real source of the topology change ?

In fact as my SSH session is open on the master and the TCN come from another switch of the stack, the source for my session is the stack port of the master switch. In order to determine which interface is really the source I have to open a session on each switch in order to find the TCN source.

For example, I have opened a session on the 2nd switch of the stack:
C3750#session 2

C3750-2# show spanning-tree detail | i from|exec|occur
 VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Number of topology changes 26 last change occurred 1w2d ago
          from GigabitEthernet2/0/52
 VLAN0040 is executing the ieee compatible Spanning Tree protocol
  Number of topology changes 26 last change occurred 1w2d ago
          from GigabitEthernet2/0/52

As you can see above, we have found the real source of the TCN.